Auteur Topic: Pagermon  (gelezen 5814 keer)

0 leden (en 1 gast) bekijken dit topic.

Offline woestric

  • Beginnend Lid
  • **
  • Berichten: 28
Re: Pagermon
« Reactie #30 Gepost op: 15 oktober 2019, 22:55:03 »
De update naar de nieuwe versie wil niet lukken, daar heb ik me voorlopig maar bij neergelegd.
Omdat de kleuren me niet bevallen ben ik bezig deze naar mijn voorkeur aan te passen.
Dat lukt me een heel eind maar de witte en iets minder witte achtergrond van de meldingen krijg ik niet gevonden, iemand die weet waar die worden gedefinieerd?

Wat gaat er niet goed? Wellicht kan ik helpen.

Die achtergrond komt uit een extern template en is dus eigenlijk niet te veranderen.
Hij staat gedefinieerd in header.ejs:
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootswatch/3.3.7/paper/bootstrap.min.css">
gr,Richard

Offline Faramir

  • Gevorderd Lid
  • ***
  • Berichten: 256
Re: Pagermon
« Reactie #31 Gepost op: 20 oktober 2019, 10:18:47 »
Wat gaat er niet goed? Wellicht kan ik helpen.

Die achtergrond komt uit een extern template en is dus eigenlijk niet te veranderen.
Hij staat gedefinieerd in header.ejs:
<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootswatch/3.3.7/paper/bootstrap.min.css">
gr,Richard

Bedankt Richard, met je verwijzing naar de header.ejs kom ik misschien wat verder.
Op de RPi de huidige versie updaten naar de 0.3.5 krijg ik niet voor elkaar. De huidige directory heb ik compleet gekopieerd zodat ik daar altijd op kan terugvallen.
Als ik de nieuwe versie uitpak over de oude wil de server niet eens starten. De configs maken daarbij niets uit, de oude en de nieuwe (aangepast volgens de instructie) heb ik beide geprobeerd.
Uiteindelijk heb ik geprobeerd op de npm install maar te draaien maar daar loop ik vast op een 'moderate severity vulnerability' die handmatig moet worden opgelost en dat hele npm gebeuren beheers is niet.
In die laatste stap van npm zat ook een eerder probleem dat er iets met SQLite te oud was.
AOR AR8200Mk3, AOR AR-DV1, RTL-SDR 820T2, Jim M-75
AOR LA400, AOR DA3200, Diamond D-777, Diamond RH-1230, Diamond MR-77B, PA0RDT mini-whip
AOR ABF128, AOR GT-1, AUTH BP 230

Offline woestric

  • Beginnend Lid
  • **
  • Berichten: 28
Re: Pagermon
« Reactie #32 Gepost op: 20 oktober 2019, 17:44:33 »
@Faramir.
Ik heb je PB gestuurd

Offline Faramir

  • Gevorderd Lid
  • ***
  • Berichten: 256
Re: Pagermon
« Reactie #33 Gepost op: 22 oktober 2019, 21:15:04 »
@Faramir.
Ik heb je PB gestuurd

Super, dank je wel! Inmiddels ben ik met je informatie aan de slag.

Grtz,
John
AOR AR8200Mk3, AOR AR-DV1, RTL-SDR 820T2, Jim M-75
AOR LA400, AOR DA3200, Diamond D-777, Diamond RH-1230, Diamond MR-77B, PA0RDT mini-whip
AOR ABF128, AOR GT-1, AUTH BP 230

Offline florisi

  • Nieuw Lid
  • *
  • Berichten: 1
Re: Pagermon
« Reactie #34 Gepost op: 4 januari 2020, 19:38:31 »
Ik heb interesse in een image voor de raspberry 3 met pagermon erop.
Kan ik die ergens downloaden?

Offline woestric

  • Beginnend Lid
  • **
  • Berichten: 28
Re: Pagermon
« Reactie #35 Gepost op: 4 januari 2020, 20:49:45 »
Je hebt een reactie op je DM ;-)

Offline sandersmit

  • Beginnend Lid
  • **
  • Berichten: 33
Re: Pagermon
« Reactie #36 Gepost op: 6 januari 2020, 20:20:50 »
Hallo,

Is er iemand die mij een stapje verder kan helpen:

Ik heb momenteel de client op een RPI draaien en de server op een Ubuntu Server VM, ik zou dit graag beide op de RPI willen draaien.

Na het installeren van NodeJS, NPM en Sqlite3 ga ik naar de ~/pagermon/server directory en maak een kopie van process-default.json naar process.json en pas het pad achter "cwd" aan. De rechten op de inhoud van ~/pagermon staat goed en heb ik recursive toegekend. (sudo chown -R pi:pi ~/pagermon)

Vervolgens voer ik in ~/pagermon/server "sudo npm install" uit en krijg een hele rits aan foutmeldingen. Zie onderstaand screenshot.

Ik hoop dat er iemand is die weet in welke hoek ik moet zoeken. Ik had al gezien dat er een image beschikbaar is via dit forum, maar zelf doen is leuker en leerzamer  ;D

Groet,

Sander

http://imgbox.com/HQWAqjYY

Offline woestric

  • Beginnend Lid
  • **
  • Berichten: 28
Re: Pagermon
« Reactie #37 Gepost op: 12 januari 2020, 14:23:02 »
Hoi,

Pagermon is erg gevoelig m.b.t. nodejs versies.
Ik  heb zelf ook problemen gehad met versie 8. JE krijgt dan oa deprecated meldingen.

Je bent nu bezig op de RPI waar je de client al op had draaien?
Wat je kan proberen is eerst NVM te installeren zodat je laatste versie nodejs kan downloaden/activeren.
curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.35.2/install.sh | bash
Daarna de meeste recente versie van node js en sqlite installeren.  Doe dit vanuit de home/pi/workspace map.
Dan weer de instructies van pagermon volgen en dus
   npm install npm@latest -g
    npm install pm2@latest -g

Dan naar de server map en npm installIn principe is sudo niet nodig...

Laat me weten als je ergens tegenaan loopt.

mvg,
Richard